Video Hotspots

This content requires HTML5/CSS3, WebGL, or Adobe Flash Player Version 9 or higher.

Video hotspots are pop up videos, they can be already hosted videos like Youtube, Vimeo or existing videos from your website